We are here for you! πŸ‘‹

Platform requirements

Teamscope has native mobile app available for iOS and Android.

For smartphone or tablet to install the app, the follow is the minimum operating system requirement:

iOS: 14.3 & newer

Android: 5.0 & newer

Teamscope has native mobile app available for iOS and Android.

For smartphone or tablet to install the app, the follow is the minimum operating system requirement:

iOS: 14.3 & newer

Android: 5.0 & newer

Still need help? We are standing by and ready to help.